Analysis Grids

This article contains information on creating and customizing an Analysis Grid.

Creating a Basic Analysis Grid 

Working with Analysis Grids

Show/Hide Columns

Sorting an Analysis Grid

Grouping an Analysis Grid

Aggregating an Analysis Grid

Changing the Pagination

Formatting an Analysis Grid

Filtering an Analysis Grid

Exporting an Analysis Grid

Saving and Managing Saved Analysis Grids

Sharing Saved Analysis Grids

 

 

Create a Basic Analysis Grid

To begin analyzing your data, you’ll want to create an analysis grid.

To create a new analysis grid:

  1. From the Reporting page, select Create/Build Analysis.
  2. Select Rename and Save to enter a new name for your analysis and select Save. Now your analysis will be available on the Reporting page from the My Items list. You can save at any point while you are working on the analysis to save it and any additional changes will be automatically saved after that.
    Under Select a set of data to begin, select one of the following data sets from the drop down list:
    Credit Debit Memo
    Flight Detail
    Invoice Detail
    People Detail
    Reservation Detail
    Session Detail
  3. The options for your selected data set are loaded. Some of the fields will be selected by default, but you can check other boxes for data you want to include in your analysis or clear boxes for data you do not want to include. Select
    OK to build the analysis based on your checked boxes.

The table of your selected data opens below the Data fields.  If desired, you can now hide the Data fields by selecting the Data tab. 


You can work with the data by sorting the data, grouping the data, applying filters, formatting the data, aggregating the data, or joining data sets.

 

To navigate the data, use the arrows and page number at the top of the table:

  • First page
  • Previous page
  • Enter a page number
  • Next page
  • Last page

Back to top

Working with an Analysis Grid

Hiding and Showing Columns

You can hide and show columns based on those included in your data for this analysis using the Table Settings.

To hide and show columns:

  1. Select the gear icon next to Table.
  2. Clear the boxes for columns you want to hide.
  3. Check the boxes for columns you want to show.
  4. Select OK to apply to changes to the table.

Back to top

Sorting an Analysis Grid

For any data set you have used to create an analysis grid, you can sort any column header from A-Z or from Z-A. 

To sort the table on a column:

  1. Select the column header.
  2. Choose the sort order.

Note that if you have blank fields, they will show first in an ascending sort order.

 

To remove a sort you have previously added:

  1. Select the column header.
  2. Choose No sort.

 

You can also use the Table Settings to fine tune one or more sorts.

To sort using the Table Settings,

  1. Select the gear icon next to Table.
  2. Select the Sort tab.
  3. Select a Data column from the drop down list.
  4. Select an Order Direction from the drop down list.
  5. Select Add.  A line will be added at the bottom of the Sort tab. This sort can be removed by selecting the trash can icon next to the sort line.
  6. Repeat steps 3-5 to sort multiple columns. The sort order is applied in the order you add the sorts. For example, in this illustration, two sorts have been added.

Back to top

Grouping an Analysis Grid

 

For any data set you have used to create an analysis grid, you can use any column header to create groups within the data set.

To group the table:

  1. Select the column header to use as the group and select Group.

A heading is added to the beginning of each group of information. This can be used together with the aggregate function to see aggregate data for each group. 

You can also use the Table Settings to fine tune one or more groupings.

To sort using the Table Settings,

  1. Select the gear icon next to Table.
  2. Select the Group tab.
  3. Select a Grouping column from the drop down list.
  4. Select Add.  A line will be added at the bottom of the Group tab. This grouping can be removed by selecting the trash can icon next to the grouping line.
  5. Repeat steps 3-4 to group by multiple columns. The group order is applied in the order you add them. For example, in this illustration, two groupings have been added.

Back to top

Aggregating an Analysis Grid

For any data set you have used to create an analysis grid, you can use any column header to aggregate information within the data set. 

Depending on the type of information in the column you select, you can see the following types of aggregate information:

  • Sum totals
  • Average
  • Standard deviation
  • Count
  • Distinct count
  • Maximum 
  • Minimum 

 

To aggregate data in the table:

  1. Select the column header for the type of information you want to aggregate. 
  2. Select Aggregate
  3. Select the type of aggregate you want to show.



You’ll see the selected aggregate information in the column header. If you have also applied groups to the table, you’ll also see an aggregate for each group. The following example shows an aggregate average.

You can also use the Table Settings to fine tune aggregated information.

To sort using the Table Settings,

  1. Select the gear icon next to Table.
  2. Select the Aggregate tab.
  3. Select a Data column from the drop down list.
  4. Select the Aggregate Function from the drop down list.
  5. Select Add.  A line will be added to show which aggregate has been applied. This aggregate can be removed by selecting the trash can icon next to the aggregate line.
  6. Position the aggregate information by selecting either Top or Bottom from the Results Positioning drop down list.
  7. Check the Hide Function Names box to show only the aggregate amount in the results, not the function name.
  8. Repeat steps 3-5 to aggregate multiple columns. The aggregate order is applied in the order you add them. For example, in this illustration, two aggregates have been added.
Back to top

Changing the Pagination

You can change how the rows of the table are displayed.

To change the paging:

  1. Select the gear icon next to Table.
  2. Select the Paging tab.
  3. To show all rows on one page, select Show all rows.
  4. To show a limited number of rows on each page, select Show paging and enter the number of rows per page.
  5. Select OK.
Back to top

Formatting an Analysis Grid

For any data set you have used to create an analysis grid, you can use any column header to add formatting based on the information in that column.

 

To add formatting, select the column header to use and select Format.

  • To align the column, select the position you want to show text in that column (left, center or right).
  • To preserve space characters, select Expanded Spaces.
  • To format numbers as a general number or currency, select the general number option or the currency option.
  • To format dates, select a Date format.
  • To color code cells based on the selected data, select Color Spectrum.
  • To add colors to cells, select Cell Colors and enter the numeric values and associated colors either by entering a hex color value or selecting a color from the color picker. Check the Color entire rows box to show the color across the whole row for affected cells.
  • To replace numbers with bar gauges, select Bar Gauges.
  • To show numbers as a percentage of the total for the selected column, select Percent of Total.
  • To remove any formatting you’ve added, select No Format.

 

Rearranging Columns and Resizing Columns

You can adjust the table to assist with the analysis of your data. 

To rearrange the columns in the table:

  1. Drag the left edge of the column to a new location.



To resize the columns:

  1. Drag the right edge of the column to a new width.

 

Back to top

Filtering an Analysis Grid

For any data set you have used to create an analysis grid, you can use any column header to filter specific information in the table.

To filter the information shown in the table:

  1. Select the column header to use as the filter. 
  2. Select Filter.

The Filter tab opens so that you can provide additional information.

  1. The column you selected is shown as the Filter column. You can choose a different one from the drop down list, if desired.
  2. Select a Comparison operator from the drop down list.
  3. Enter the Value you want to filter using that comparison.
  4. Select Add to apply the filter. A line will be added in the Filter tab. It can be removed by selecting the trash can icon next to the filter line.

 

You can apply additional filters. Repeat steps 3-6 in the Filter tab to add another filter line.

 

With multiple filters, you can change the AND connector to an OR connector. AND will locate only records that match both filters, while OR locates any record that matches either one filter or the other.

Select the Filter tab again to hide the filter information.

 

Back to top

Exporting an Analysis Grid

For any data set you have used to create an analysis grid, you can export the resulting table to work with the information outside of FlightSchedule Pro.

 

To export a table:

  1. Work with the analysis grid by hiding/showing columns, sorting, grouping, formatting, and filtering the information.
  2. When the table includes the information you want to export, select Export and choose the export format. Note that CSV files will not include formatting.

Back to top

Working with Saved Reports

When you name and save an analysis grid, it appears at the top of the Reporting page in My Items, which is shown by default.

If another Flight Schedule Pro user has shared a report with you, select the Shared with Me tab to see the list of shared reports. This list includes several visuals shared by Flight Schedule Pro.

Locating an Analysis

You can use the Search bar to locate a report or analysis grid.

To search for an item on the Reporting page:

  1. Enter the first few letters of the name of the item in the Search field.
  2.  The top section of the Reporting page is filtered to show only items that match the Search field text.

 

Organizing Items on the Reporting Page

You can create folders to organize the reports and analysis grids you have created, as well as those that have been shared with you.

To create a folder:

  1. Select the gear icon to the right of My Items.
  2. Select Add New Folder.
  3. Enter a New Folder Name.
  4. Select Done.

The new folder appears under My Items.

A gear icon appears next to the new folder, allowing you to add a new folder, rename the existing folder, or delete the existing folder.

 

To move an analysis to a new folder, drag the item from the list on the right to the folder on the left.

 

Back to top

Sharing Items on the Reporting Page

You can share your analysis grids from the Reporting page.

To share an item:

  1. Select the Options button to the right of the name of the item you want to share.
  2. Select Share.
  3. Begin typing the name of the person to display your Flight Schedule Pro users.
  4. Select the row for the person with whom you want to share the analysis.
  5. Select Close.

You can stop sharing an item by selecting the trash can icon next to the name of that person under Shared With.

Note: Users need to have permission to the specific reports sections contained in the Shared Analysis Grids

Back to top